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QuickBooks Link Manual 
Introduction 
QuickBooks Link was created to summarize and transfer accounting information directly into 
QuickBooks.  We recommend QuickBooks as an excellent general accounting package for the 
small business.  It is easy to use and has quite a bit of support in the marketplace. 
 
QuickBooks Link will open up account numbers in all financial transactions throughout CLIP.  In 
every Job, every debit, every credit, every installment, etc., you will be able to enter a valid 
QuickBooks account number that will help you classify your accounts much more thoroughly than 
ever before. 
 
QuickBooks Link will summarize this financial activity and create a file that QuickBooks can 
import, eliminating any human errors.  The information is received in QuickBooks as single line 
items that show up on your Balance Sheet and Income Statement. 
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Preface: Setting up Contract Customers for the QuickBooks Link. 
 
Please read the following article if you have or will ever have monthly 
installment customers. You may decide to change your chart of accounts 
in QuickBooks.  If you are not using contract customers, you may want to 
disregard this section. 

 
The Linking programs and the problem with contract 

installments and payments 
 

Or 
 
How do I track both the Charge per Job and the Installments for 
my Contract customers when I use either QuickBooks Link or 

Clinker with CLIP? 
 
Over the years we have tried numerous approaches to the idea of linking contract installments 
over to the General Ledger along with the amounts we charge for each job when the job is 
performed. 
 
Let’s delineate the challenge: 
 
•  Customer Jones pays me $100/month for 8 months in exchange for me servicing his 

property: What do I place in the Charge Per Job of the service? 
 
The formula for this is $100 times 8 months = $800 divided by the total number of services in the 
year (30) equals the Charge Per Job: 
 

100 X 8 = 800 / 30 = $26.67 
 
In this case, I would place $26.67 into the Charge Per Job field of the installment job.   
 
Now, what would I place in the Credit and Debit account numbers for linking purposes?  For our 
first decision, we must ask ourselves, which amount would I want to track as my sales amount, 
the installment or the job?  
 
The customer pays me the installment ($100) each month, so that would seem to be what I want 
to track, but we end up with false or at least misleading information if we track only the 
installment.  Let’s take a simple example: 
 
Tracking the installment: 
 
Month:               May 
 
Sales:  $100.00 (from the installment) 
 
Expenses: $120.00 (from my labor, supplies and overhead) 
 
Profit:  $20.00  (A net loss for the month) 
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By using this P & L, I would start to make decisions to reduce my expenses and panic since I will 
soon be out of business.  This is a false impression since our expenses were higher than normal 
because of having to service the property 5 times instead of the usual three or four due to 
weather conditions.  Since our obligation to the client is 30 visits per year, we have really 
performed $133.35 worth of work for the customers (26.67 x 5).  We know that the customer has 
not paid us for the extra services yet, but we also know that he will pay us later when we slow our 
services down, but he still pays us the $100.00/month that we are due. 
 
If we were to track the Charge Per Job instead of the installment in the link program, the P & L for 
the same month would look more like this: 
 
Tracking the Charge per Job: 
 
Month:               May 
 
Sales:  $133.35 (from the charge per job) 
 
Expenses: $120.00 (from my labor, supplies and overhead) 
 
Profit:  $13.35  (A profit for the month) 
 
This scenario is much more realistic.  We did not receive $133.35 in cash but we did do the work 
worth that and our expenses reflect that we incurred that in costs.  This P & L will give us less 
worry and will help us build our company on a better financial basis.   
 
To see this even more starkly, let’s look at the two scenarios when the work slows down and we 
only visit the property once in a month: 
 
Tracking the Installment: 
 
Month:                 August 
 
Sales:  $100.00  (from the installment) 
 
Expenses: $20.00  (from my labor, supplies and overhead) 
 
Profit:  $80.00  (An unrealistic profit, since we only serviced the customer once.) 
 
 
Tracking the Charge Per Job 
 
Month:   August 
 
Sales:  $26.67  (from the charge per job) 
 
Expenses: $20.00  (from my labor, supplies and overhead) 
 
Profit:  $6.67  (A realistic profit for the month) 
 
 
Now we can see by this example that the best way to track the sales is by using the Charge Per 
Job and not the Installments.  But it goes against common sense not to track the actual money 
that came into the company as the sale.  So, wouldn't it be nice to track them both? 
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If we track the Installments as Installment Sales and the Charge Per Job as sales, our numbers 
could be way off.  For the month of May, we would end up with $233.35 in sales, $133.35 from 
the Charge Per Job and the $100.00 from the Installment.  We know that this is wrong, so there 
must be another way.  Since we want to track both the Installments and the Charge Per Job, and 
we do not want them to “add up” in our sales figures, let’s come up with a new method…. 
 
In the Job Credit account number we could have a GL account that would be “Contract Sales”.  
Our Debit account number would be the Accounts Receivable (AR) account.  This would cause 
the $133.35 to be placed as a sale in our P & L.  When we received the $100.00 payment it would 
reduce the Accounts Receivable and increase the cash account.  Since the AR account went up 
by 133.35 and then was reduced by 100 because we received a check, we would correctly see 
on our Balance sheet that there is still $33.35 in AR.  This is the amount that the Charge per Job 
has exceeded the monthly installment.  Our P & L would still be correct. 
 
We still want to track the installment itself.  One method to do this would be to create two sales 
accounts, one called Sales Installments Credit and the other called Sales Installments Debit.  We 
could place these into the installment screens of our contract customers.  Since CLIP will Credit 
one account and Debit the other we would see the two accounts with exactly the same amount in 
each, one a positive number the other negative.  When they are added together they produce 
0.00 which will keep our numbers from being untrue and yet give us the numbers for the 
installment amounts so that we will be able to see our installments in the P & L.  It would look like 
this: 
 
Tracking the Charge Per Job and the Monthly Installments 
 
Month:    May 
 
Sales:   $133.35  (from the charge per job) 
 
Sales Installments: 
 Debit  $100.00  (from the installment) 
 
Sales Installments 
 Credit  -100.00   (from the installment) 
 
Expenses:  $120.00  (from my labor, supplies and overhead) 
 
Profit:    $13.35 (A profit for the month) 
 
 
As we get nearer to the end of they year, we will be able to compare the YTD installment 
amounts with the Sales from Contract jobs and see how close we are.  If we have estimated our 
Charge Per Jobs correctly, the two sets of numbers should be very close. 
 
You may decide to have two sales accounts for each category, such as Sales Maintenance and 
Sales Maintenance Contract. You will need these for any non-contract work, otherwise, when you 
compare the totals, they will be incorrect 
 
You may need to make a journal entry at the end of the year to correct for the actual money 
received. 
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Section 1: Setting Up Account Numbers in QuickBooks   
You must use account numbers in QuickBooks for the QuickBooks Link to work properly.  
QuickBooks uses account names not account numbers; these account numbers must be 
enabled.  If you do not have accounts numbers enabled, conduct the following procedure: 
 
Note: At the end of this section are important notes that should be referenced to ensure 
correct set-up of the QuickBooks account numbers. 
 
QuickBooks ’99: Go to File>Preferences… 

 

   
 

QuickBooks 2000/2001: Go to Edit>Preferences… 
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…Select, from the left-side menu, “Accounting,” and then the “Company Preferences” tab.… 
 

 
 
…Click “Use account numbers” and “Require accounts.”  When finished, click “OK.” 

 

 
 
QuickBooks will assign some account numbers automatically using accepted standard 
accounting numbers commonly used in practice.  
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IMPORTANT NOTE: If you’ve just started using account numbers and set up your sales accounts 
through the setup wizard, you will not have account numbers for your sales accounts.  If this is 
the case you must edit and assign a number to each sales account.  Also, you must assign 
numbers for all of your accounts that you’ve entered previously into QuickBooks. 
 
A fast way to do this is to use the “Account list” button from the top of the QuickBooks screen - 
highlight each Sales account and press <Ctrl>+<E> to edit the account.  Or you can go to 
Lists>Chart of Accounts and press <Ctrl>+<E>.  We recommend that you use income account 
numbers in the 41000 range since this is a commonly accepted practice in accounting.   
 
Enter the account number into the “Number” field in the “Edit Account” window, then click “OK.” 
 

 
 
Before you continue, make sure all of your accounts have account numbers.  CLIP will not be 
able to use any accounts that do not have these required numbers. 
 
IMPORTANT NOTES:  
 
•  The only QuickBooks’ account types from the Chart of Accounts that will transfer to CLIP 

are Accounts Receivable, Bank, Income, and Other Current Liabilities. 
 
•  The Sales Tax account cannot be named “Sales Tax Payable.”  QuickBooks relates this 

name to a Vendor type of account, which will not work with CLIP. You will get an error at the 
EOM transfer if this name is used; if you still get an error at the EOM transfer you may need 
to create a new sales tax account in QuickBooks and do an “Erase and Re-import” from the 
Clip’s QuickBooks Link setup screen. Assign all the account numbers as before, except 
change the Sales Tax account to the new one you just created. 

 
•  Go to System>Set Tax Area to change the account number for your Tax Area.   
 
•  Clip will work with QuickBooks’ sub-accounts. 
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Section 2: Exporting the Chart of Accounts from QuickBooks 
 
After assigning account numbers to your QuickBooks’ accounts, you will need to Export your 
Chart of Accounts from QuickBooks to CLIP.  The following instructions are for performing the 
Export operation in both QuickBooks ‘99 and QuickBooks 2000/2001.   
 
Note:  When instructed to “click” or “select” a function or file, this will mean a “left” mouse click 
unless indicated to “right” click on the function or file. 
 
QuickBooks ’99: Go to File>Export - Select “Export” from the “File” menu. 
 

 
 
QuickBooks 2000/2001: Go to File>Utilities>Export - Select “Export” from the “Utilities” menu. 
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You will see the Export dialog box: “Check” the “Chart of Accounts.”  Click “OK.” 
 

 
 
When the Export dialog window is initially opened, you’ll most likely be in the QuickBooks folder.   
The name of the file, as a default, will be “*.iif.”  The “Save as Type” should be “IIF Files (*.IIF)”. 
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You will need to change the file name.  Click in the “File name” field in the Export window and 
change the name of the “*.iif” file name to “clip.iif”, the correct name for the Chart of Accounts. 
 

 
 
You will need to locate your CLIP folder.  This can be accomplished by clicking on the drop-down 
arrow in the “Save in” field and locating where your CLIP is installed, which is often the c:\ drive. 
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Once you’ve chosen the correct drive, locate, click the CLIP folder and click “Open.”  
 

 
 
After opening the CLIP folder, locate and click the “Dbf” folder and then click “Open.” 
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Once you’ve opened the “Dbf” folder, save the “clip.iif” file by clicking “Save.” 
 

 
 
QuickBooks will present you with a dialog box: “Your data has been exported successfully.”   
 
Go ahead and click “Ok” to finish the process. 
 

 
 
If you do not receive this message, repeat the process until you are successful.  If the process 
has been completed correctly, you should have a “clip.iif” file in your CLIP Dbf folder. 
 
For now, you are done with QuickBooks—you may close the program and open CLIP to continue 
with the process. 
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Section 3: Importing the Chart of Accounts into CLIP 
This section will explain the process for importing the QuickBooks Chart of Accounts into the 
QuickBooks Link Set-up. 
 
Note: At the end of this section are Additional Notes that may prove useful for any problems with 
this process. 
 
In CLIP, to import the Chart of Accounts, go to the Other Modules >QuickBooks Link option.  
 

 
 

Click the “Setup QB Link” button under “Setup” in the QuickBooks Link window. 
 

.  
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This will bring up the QuickBooks Link setup screen: Click on the “Import Account Numbers” 
button in the upper right hand corner. 

 

 
 
If you’ve correctly imported your QuickBooks Chart of Accounts, you will see a dialog box… 
 

 
 

…Indicating that the import was successful.  Go ahead and click “OK.”  If you have reached this 
point, you have successfully imported your Chart of Accounts into CLIP and can proceed to the 
next section to start setting up the QuickBooks Link.  If you do not receive the above message, 
see the next page for Additional Notes for continuing with the importing of the Chart of 
Accounts. 
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ADDITIONAL NOTES:  
 
•  If you saved the Chart of Accounts to a location other then the CLIP “Dbf” folder, a window 

will appear asking you to locate the “clip.iif” file.  You will need to manually find the “clip.iif” 
file to finish the importation process.  Locate, click, select the file, and then click Open.  This 
will import the “clip.iif” file.   

 

 

•  If you have imported the Chart of Accounts previously, a message will appear asking if you 
would like to continue with the procedure: 

 
 
You should only click “Yes” continue with this procedure if you are re-importing your Chart of 
Accounts from CLIP.   This would be done if, for example, you’ve added accounts to your 
QuickBooks Chart of Accounts and would like for this new account to appear in your 
QuickBooks Link set-up.  If this is not your intention and you do not want to re-import your Chart 
of Accounts, you shouldn’t continue with this procedure, and would therefore click “No”. 
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Section 4: Filling in your default accounts in QuickBooks Link 
 
Clip requires you to fill in all the account fields, even account fields that you may not use. (These 
numbers will be assigned as default to all existing jobs.)  If you have multiple income accounts, 
choose the one that will cover most of all the jobs that you currently have.  You can then change 
the number in the individual job or transaction.  Simply enter the account number into each field. 
 
If you do not know the account numbers, click in the account field and hit the <Enter> key.  (This 
is the method that we recommend.)   
 

 
 
A screen will appear with the imported Chart of Accounts—select the desired account(s). 
Click the account in the list and click <Enter> for the account to appear in the fields. 
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Go ahead and select--into each Credit and Debit field--the desired account numbers. 
 

 
 

NOTE: You must have an account number in every account field, even if you’re not using that 
particular code or account in your operation of CLIP.  CLIP requires, by default, an account 
number in every field in the QuickBooks Link set-up. 

 
When all the accounts are filled out you can proceed to the “Save and Activate” button. 
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This will start the process of collecting data from CLIP to be transferred to QuickBooks and any 
data that you have in CLIP before you activate the link will not be sent to QuickBooks.  Only new 
data from this point of time will be transferred. 
 

When you have “Saved and Activated” the link, you will see a dialog box… 
 

 
 
…Indicating the activation was successful.  You may press the “Return” button to enter back into 
CLIP. 
 
At this point, your QuickBooks Link is set-up.  It’s vital, though, that you make sure you are using 
the numbers that are correct for your QuickBooks set-up.  The next section will discuss some 
theory behind the proper set-up of the QuickBooks accounts in the QuickBooks Link set-up. 
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QuickBooks Link Setup  
 

 
 

Note: The above picture is for example purposes only. Consult your 
accountant for the best setup for your company. 
 
Important Note: You CANNOT use the same account numbers for both the Credits and Debits of 
the same code.  Using the above example, you wouldn’t have account (1200) Accounts 
Receivable for both the Credits and Debits of the “C” Cash.  It should be mentioned again that 
this only applies, per line, for the same code type. 
 
Double Accounting Entry System 
 
For accuracy, CLIP uses a “Double-Entry Accounting System”.  This means that every activity 
in CLIP will affect at least two QuickBooks accounts.   
 
For example:  
 
You mowed a job for Mr. Smith.  This mowing job, Mow and Trim, has a Charge Per Job of 
$40.00, and is considered a “L” taxable labor.  Since, per the above example, your Taxable Labor 
Credit is set up for the (4700)—Contract Sales account, the $40.00 will go into this account. 
 
Mow and Trim Job = $40.00 charge = $40.00 credit = (4700)--Contract Sales Maintenance  
 
You now have $40.00 credit in your QuickBooks’ (4700) Contract Sales Maintenance account. 
 



   23 
 
 

The following is a typical example of a double-entry transaction.  If you mowed the lawn for Mr. 
Smith you would now have more money in Receivable and you want to credit Sales. Your 
Receivable has gone up by $20.00 because he now owes you $20.00.  Your sales will be 
credited by $20.00 to show you that you have done $20.00 in sales.  As you go through the year 
you will find that your sales continue to increase in negative numbers.  When Mr. Smith gives you 
$20.00 in payment your Account Receivable will be reduced because you have received the 
money and your as will increase because you deposited it into your account.  When you buy gas 
for your trucks at the local gas station for $20.00 your cash will decrease by $20.00 and your gas 
expense account will increase by $20.00.   CLIP, of course would only be concerned with the first 
two sets of transactions.  In order to use CLIP with QuickBooks you will have to tell QuickBooks 
Link which accounts to credit and debit for each type of transaction.  (If you classify your sales by 
"type," you can get detailed in these transactions.)  If you need more accounts, you will have to 
add them in QuickBooks and then transfer them to QuickBooks Link again in the same manner as 
described above. 
 
The example is set up for a company with installment customers. Notice 
the installment account numbers do not affect A/R or income accounts. 
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Section 5: Checking your Jobs for proper Account Information 
 
After setting up the QuickBooks Link, per the previous instructions, your jobs and all financial 
activities in CLIP will be activated. But, you may want to adjust your jobs so that you can get more 
specific with your sales.  Also, you can add account numbers in QuickBooks at any time and go 
through the import process once again.   
 
Note: Remember to change your pattern jobs so that all your new jobs will reflect the correct new 
account numbers. 
 
If you are intending to have specific account numbers for each job(s), the Credit and Debit 
accounts need to be entered into the Job Details of each job.  This can be performed by going to 
Files>File Maintenance>(Select Customer)>Jobs>See Details.   
 
Once inside the Job Details screen, click the Credit or Debit fields located near the bottom of the 
Job Details screen and click <Enter>. 
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After clicking <Enter>, the “Choose Valid Account” screen will appear. 
 

 
 
If you want to add an account, click in the account’s field to select the desired account and click 
<Enter>. 

 
After selecting the account, the account’s number will appear in the Credit or Debit account. 
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Section 6: Releasing the Financial Information 
 
As you go through the month, you will begin to accumulate financial information in your files in 
CLIP.  When you are prepared to transfer the financial information, you will have to tell 
QuickBooks Link to summarize, export, and release the financial information to QuickBooks, a 
process that you can perform as often as you desire.   
 
This process can be easily accomplished by going into the QuickBooks Link menu and choosing 
“Financial Information and Release,” opening “Quick Books: Reports and Release.” 
 
 

 
 
STEP 1: Process Information 
 

Click “Continue with Process” to start the summarizing and exporting of the data. 
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STEP 2: Print Reports 
 
After clicking “Continue with Process,” the Quickbooks Link will go through all of your financial 
information and summarize it into only the accounts that have been used.  The detailed 
transactions could number in the thousands, but when they are all summarized, there will 
probably be only a few accounts. 
 
The information will be summarized in the Link Report.  You have the choice of two different 
types of reports to view the information that is being released: 
 
•  Transactions to Release/Detail 
 
•  Transactions to Release/Summary 
 

 
This step will allow you to examine the number of transactions that are being released.  You can 
examine a report on what is occurring by pressing the Process Report button.  You also have 
the option to change the destination of the report: 
 
•  Screen: This will display the Link Report on the screen.   
 
•  Print: This option will allow you to print a copy of the Link Report; this is recommended for 

future record-keeping purposes. 
 
•  File: This option will allow you to save a copy of the Link Report in a file format.  It’s 

recommended that you save a copy of the report for future record purposes. 
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If you select “Transactions to Release/Detail,” the following screen will appear.   
At the top of the screen, you’ll notice a “Print Preview” print window.  This window allows you to 
scroll through the pages of the report, if the report has more then one page, to increase the 
viewing size of the report, and to send the report to your printer. 

 

 
…And the information will be displayed in the below format.  
 

 
If you select “Transactions to Release/Summary,” the following information will be displayed. 
 

 
This report will display the General Ledger information that is being transferred: Description, 
amount, and account number.  
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Step 3: 
 
The final step in the process is to “Process the Close.”  You will see the following message in 
Step 3, explaining its function: 
 
“This function will close the Quick Books Period and transfer the Information to Quick 
Books file in the DBF directory to be drawn into Quick Books.”  
“If you wish to close the period without transferring the information to the Quick Books 
ledger, choose ‘Close, No Release to QB from the previous menu.” 
 
When you press “Process the Close,” QuickBooks Link will take the summary and create an 
“.iif” file that QuickBooks can read to import into the accounting system. 
   

 
 

QuickBooks Link will tell you where the file is being saved, and its name. 
  
Important Note: Make sure you know exactly where the file is being saved! 

 
The name of the file is the same as the date that the file is transferred, followed by an “A” if it is 
the first transfer of the day. Any subsequent transfers the same day will have the next available 
alphabetical letter assigned to it. Make sure you take note of the file name, you’ll need to be 
aware which “.iif” file you are importing into QuickBooks. 
 

 
 
Next you will see the note that the QuickBooks' period has been closed.  This does not affect 
your CLIP period closings.  All new data entered into CLIP will start accumulating again so that 
QuickBooks Link will be ready to release again.  You can release information as often as you like.  
This has no effect on your CLIP system.   
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Section 7: Importing into QuickBooks Pro  
 
Once you have released the information from CLIP, you will now have to import the information 
into QuickBooks.   You can accomplish this by going into QuickBooks, pulling down the File 
menu and clicking the Import option. 
 

 
 

 
You will then receive an “Import” dialog box. 

 

 
 
 

 
 
 



   31 
 
 

Locate the “.iif” file by clicking in “Look in” field at the top of the “Import” screen. 
 

 
 
 
Locate the correct drive and then the CLIP folder, which is usually on the c:\ drive by default.  
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Locate and select the “Dbf” folder and click “Open”… 

 

  
 
 

Select the “.iif” file that the QuickBooks Link created and then click “Open.” 
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If the process export/import process was correctly performed, you will receive a prompt… 
 

 
 

Indicating “Your data has been Imported.”  Click “OK” to finish the process. 
 
Congratulations! You have successfully imported the information from CLIP into QuickBooks.  
You will see that the Balance Sheet and the Income Statement have been affected by the 
information from CLIP. 
 
You can export from CLIP and import into QuickBooks as often as you like.  We suggest that you 
do it at least once a month. 
 
NOTE: Should you get and error on line 9 (see example below) on the first transfer. Go to your 
vendor list in Quick books. Find the vendor called CLIP - LINK INFO.  Delete this vendor. Create 
a new customer in QuickBooks with the exact same name, CLIP - LINK INFO. It must be spelled 
EXACTLY as shown. It is only necessary to enter the name of the customer.  This will 
permanently solve the problem. 
 

 
 

Other Reports you can use. 
 
Under the Reports>Sales Report>Sales by Account Type function you can ask CLIP to list out 
your transactions by account number.  This gives you better financial information. 
 
Under the User Defined Lists (Reports>Custom Reports>User Defined List), you can now get a 
report based on the credit and debit account numbers.  This helps you get better business 
information. 
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